MPmail portal currently not working
Incident Report for Manage Protect Pty Ltd
Resolved
Portal has been returned to full functionality.
Posted May 13, 2019 - 14:11 AEST
Identified
Expected to be back online at 2pm AEST.
Posted May 13, 2019 - 14:00 AEST
This incident affected: MPmail.