Monitoring - Backup365 have implemented a fix which should cause the sync rates to normalise over the next couple of days. We will be monitoring them from our end and provide an update accordingly.
Apr 11, 2024 - 12:33 AEST
Investigating - We are aware of an issue with Backup365 re-adding deleted unlicensed mailboxes into the backup schedule. This is artificially lowering the sync rates shown on Backup365 reports and the portal. Please be assured that actual mailboxes are still being backed up and you will not be billed for any mailbox backups that have been requested for deletion despite them appearing again. Please contact support@manageprotect.com if you have any questions or concerns. Backup365 has been made aware of the problem and we will advise when there is an update.
Apr 05, 2024 - 12:36 AEDT
MPmail ? Operational
MPexchange ? Operational
Datto / Autotask Workplace Operational
MParchive Operational
MPAV Operational
MPweb Operational
Backup365 ? Degraded Performance
CloudAlly Operational
Microsoft 365 Operational
Service Desk & Support Systems Operational
Service & Feature updates ? Operational
Converge ? Operational
90 days ago
95.34 % uptime
Today
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Major outage
Partial outage
No downtime recorded on this day.
No data exists for this day.
had a major outage.
had a partial outage.
Past Incidents
Apr 16, 2024

No incidents reported today.

Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

Unresolved incident: Backup365 Deleted Items and Sync Rates.

Apr 10, 2024

No incidents reported.

Apr 9, 2024

No incidents reported.

Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024
Apr 4, 2024

No incidents reported.

Apr 3, 2024

No incidents reported.

Apr 2, 2024

No incidents reported.