Converge Office 365 Display not rendering
Incident Report for Manage Protect Pty Ltd
Resolved
This issue has been resolved. Provisioning from Converge is available.
Posted Jun 07, 2021 - 16:33 AEST
Investigating
Converge is current not rendering the display of licenses for Office 365. We are currently investigating the issue. Manage Protect can still provision licenses for you, feel free to email or call us with your requirements.
Posted Jun 07, 2021 - 14:45 AEST
This incident affected: Converge.