Phones not working
Incident Report for Manage Protect Pty Ltd
Resolved
Phones are back up and running now. Issue resolved.
Posted Jul 05, 2019 - 10:42 AEST
Investigating
Currently the Manage Protect phone service is unavailable. We are working to fix this ASAP. Please conduct support request through emailing support@manageprotect.com or through chat at manageprotect.com
Posted Jul 05, 2019 - 08:26 AEST
This incident affected: Service Desk & Support Systems.