MPmail portal at https://control.manageprotect.com not working
Incident Report for Manage Protect Pty Ltd
Resolved
The MPmail control panel has now returned to be fully functional. The SSL certificate for the site has also been restored.
Posted May 12, 2019 - 15:36 AEST
Identified
Issue has been identified -- we expect resolution within the hour. If you request urgent assistance within that time period, please contact our service desk team on 1300 657 500.
Posted May 12, 2019 - 15:12 AEST
Investigating
Presently, https://control.manageprotect.com is not available. If you urgently need mail released, please contact the After Hours Emergency service on 1300657500(AU) or 0800 141 481 (NZ)
Posted May 12, 2019 - 14:29 AEST
This incident affected: MPmail.