MPmail Control Panel issues
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted May 14, 2019 - 16:34 AEST
Identified
MPmail Control Panel is currently not resolving for some users.
If you have issues, please reach out to support.
We expect this to be resolved by 2pm AEST.

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted May 14, 2019 - 13:18 AEST
This incident affected: MPmail.