MPexchange 2FA for administrator accounts
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted May 20, 2022 - 11:44 AEST
Investigating
As the result of recent global security threats we have been forced to implement 2FA for your MPexchange admin logins. We apologise for the extremely short notice on this change — and if you have any questions or require assistance please contact us.

Your options for MFA are:
SMS text message
Voice Call
Authenticator app
DoubleSafe app

If you have a common login for multiple technicians, you may need to create individual logins
Posted May 20, 2022 - 10:12 AEST
This incident affected: MPexchange.