MPexchange billing issue
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Jul 20, 2024 - 09:11 AEST
Identified
Due to the change of API for MPexchange billing, the source for billing quantities was changed in our billing process. Unfortunately, as MPEXD is a “bundle” of MPmail, Dropsuite and hosted exchange the “bundle roll-up” component didn’t run on the final billing run resulting in the quantities not updating correctly.

We will be issuing credit notes to all accounts impacted on Monday. We will also partially refund all credit cards that have already been transacted. Connectwise Integration will have the correct data in place as of today. We apologise for any inconvenience or re-work we have caused.
Posted Jul 06, 2024 - 12:56 AEST
Investigating
Hello, invoices have been sent however we have noticed an anomoly where it appears some MPexchange customers have been billed an extra mailbox for their Dropsuite Mailbox Backup service. We are working to resolve this, and will advise later this morning / early this afternoon. We sincerely apologise for any inconvenience caused.
Posted Jul 05, 2024 - 10:28 AEST
This incident affected: MPexchange and Converge.