Datto Workplace Agent Not Connecting

Incident Report for Manage Protect Pty Ltd

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 10:03 AEDT

Update

Datto Workplace FileSync and WebUI download functionality appears to have been restored. All tests appear to now be functional and working as expected.

If you are still having issues please reach out to our support team to assist.
Posted Nov 20, 2025 - 17:05 AEDT

Investigating

We are currently aware of an issue affecting Datto Workplace services. Based on our investigation, this appears to be a system-wide issue impacting multiple customers.

We have escalated the matter directly to Datto and their engineering team is actively investigating.
Posted Nov 20, 2025 - 10:43 AEDT
This incident affected: Datto / Autotask Workplace.