MPexchange - MFA SMS issue
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Jan 03, 2024 - 13:06 AEDT
Monitoring
The MPexchange web access login using SMS issue has been resolved.

There may be issues with the Double Safe MFA, we are still investigating.
Posted Dec 14, 2023 - 08:14 AEDT
Update
When logging in to MPexchange web access, and when your MFA is set to SMS, the login may report 'phone number not registered'.

Our development team is still working on the resolution, this should be resolved in 24 hours.

For now, as a workaround, please use voice call instead of SMS.
Posted Dec 13, 2023 - 16:12 AEDT
Investigating
When logging in to MPexchange web access, and when your MFA is set to SMS, the login may report 'phone number not registered'. The other MFA methods are unaffected. The issue is being investigated by the MPexchange engineers.

Mail flow and Outlook access are unaffected.

The only workaround is to have your IT support log in to the portal and either disable or switch to an alternate method of MFA.
Posted Dec 12, 2023 - 13:01 AEDT
This incident affected: MPexchange.