Manage Protect Invoice run delayed to the 4th of July 2024
Incident Report for Manage Protect Pty Ltd
Resolved
The invoice run has been processed.
Posted Jul 20, 2024 - 09:11 AEST
Identified
Hello, invoices have been sent however we have noticed an anomoly where it appears some MPexchange customers have been billed an extra mailbox for their Dropsuite Mailbox Backup service. We are working to resolve this, and will advise later this morning / early this afternoon. We sincerely apologise for any inconvenience caused.
Posted Jul 05, 2024 - 10:12 AEST
Investigating
Hello, unfortunately the Manage Protect monthly billing run has been delayed this month and is expected to go out on the 4th of July 2024. This is due to the deprecation of one of our technology partners billing API and subsequent delay of billing information being received. We are aiming to have this resolved for next month, and apologise for any inconvenience caused to our partners.
Posted Jul 03, 2024 - 14:44 AEST
This incident affected: Converge.