Issue managing Microsoft Subcriptions

Incident Report for Manage Protect Pty Ltd

Resolved

The issue has been resolved and managing Microsoft subscriptions in Converge is back to operational.
Posted Jan 16, 2026 - 18:04 AEDT

Update

We are continuing to investigate this issue.
Posted Jan 16, 2026 - 15:57 AEDT

Investigating

We are currently aware of an Issue where Microsoft subscriptions are not showing under customers in Converge. The create tenant window is being displayed instead. Our Development team is currently working to resolve the issue
Posted Jan 16, 2026 - 15:57 AEDT
This incident affected: Microsoft 365 and Converge.