MPmail Control Panel Login Issues
Incident Report for Manage Protect Pty Ltd
Resolved
This has now been resolved. Functionality to the MPmail Control Panel is restored.

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted May 08, 2019 - 14:10 AEST
Investigating
We are currently investigating reports of users getting disconnected from the MPmail Control Panel control.manageprotect.com
Updates to follow.

support@manageprotect.com
chat.manageprotect.com
1300 657 500
Posted May 08, 2019 - 13:22 AEST
This incident affected: MPmail.