Our technical team has taken steps to mitigate the issue affecting login to mailboxes via Outlook Mobile and Desktop, native mail applications, and OWA. If you are still experiencing issues after a password reset, please contact the support team.
Posted Apr 29, 2026 - 17:15 AEST
Monitoring
The issue affecting MPExchange connectivity via the built-in iOS Mail app has been investigated.
If users continue to experience issues, resetting their password appears to resolve the problem in most cases.
We recommend attempting a password reset and reconfiguring the account if required.
If problems persist after this step, please contact support for further assistance.
Thank you for your patience while we worked through this issue.
Posted Apr 28, 2026 - 09:33 AEST
Update
We are currently investigating an issue where MPExchange is not functioning as expected when accessed via the built-in Mail app on iOS devices.
At this stage, the Outlook Mobile app appears to be operating normally and can be used as a temporary workaround.
Our team is actively working to identify the root cause and will provide further updates as more information becomes available.
Posted Apr 25, 2026 - 11:14 AEST
Update
The MPexchange engineering team has identified an issue affecting login to mailboxes via Outlook and other mail clients and are actively working to resolve it. Affected users may utilise Outlook Web App (OWA) while the issue is being addressed. We apologise for the inconvenience and will provide an update as soon as more information becomes available.
Some users may encounter login errors or continuous password prompts when attempting to connect to their mailboxes via Outlook or other mail clients. Users should be able to access their mailboxes via Outlook Web App (OWA) normally.
Posted Apr 24, 2026 - 16:33 AEST
Investigating
We are currently investigate an issue where some users are unable to log into their MPexchange mailboxes. We have noticed this only effecting some customers and not extended to all users.