MPexchange service not connecting
Incident Report for Manage Protect Pty Ltd
Resolved
All MPexchange services should be operating normally. With the disconnect, you may need to confirm, or possibly reset, then re-enter your email password.

If you do have further issues, please contact support on 1300657500, or via email to support@manageprotect.com. We also have a chat service at https://converge.mp/
Posted Jul 22, 2024 - 09:40 AEST
Monitoring
CrowdStrike has identified, isolated, and deployed a fix for the issue. As a result, more and more of the MPexchange systems and services are returning to their normal state. Like all impacted organizations, we are working diligently to fully restore all our services. We will continue to keep you updated until the impact from the CrowdStrike incident is fully resolved.

Some Account Administrators may continue to experience issues with log in to Control Panels. Some users may continue to experience degraded performance connecting to services.

Thank you for your continued patience and understanding.
Posted Jul 20, 2024 - 09:06 AEST
Update
CrowdStrike has identified, isolated, and deployed a fix for the issue. Like all impacted organisations, we are now working to restore all our services. While most of our services are operational, some MPexchange services remain affected, and our teams are working tirelessly to resolve this as quickly as possible. We will keep you informed as we have more updates. Thank you for your continued patience and understanding.
Posted Jul 19, 2024 - 23:01 AEST
Update
A reminder that MPexchange customers are able to continue accessing their email through their Message Continuity service —- and view emails through https://mpmail.com.au . Please contact our support team if you require assistance with this on 1300657500 [AU] / 0800 141 481 [NZ]
Posted Jul 19, 2024 - 22:42 AEST
Update
We believe the root cause is a major worldwide tech outage, believed to have been caused by a flawed anti-viral update from US cyber security company CrowdStrike. The issues have impacted the some of the biggest companies around the world, including banks, IT companies and even airports, leading to some flights being grounded.
It is understood a flawed update was rolled out globally, shutting companies out of access to computers.
Posted Jul 19, 2024 - 16:52 AEST
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 16:50 AEST
Update
We are continuing to investigate the issue. Emails are still being delivered to the MPexchange servers, and are being accepted, and will be available as soon as the connection issues are resolved.
We apologise for the inconvenience. Unfortunately we are unable to give an ETA for resolution as the root issue is still being determined.
We will be posting updates as information becomes available.
Posted Jul 19, 2024 - 15:53 AEST
Investigating
The MPexchange service is reporting login errors from Outlook, and also generating an error from the webmail page. We are investigating the cause as a matter of urgency.
Posted Jul 19, 2024 - 15:14 AEST
This incident affected: MPexchange.