Exchange Services not responding
Incident Report for Manage Protect Pty Ltd
Resolved
Installation of Microsoft Software updates for the exchange server EXCH690 have been completed.
Posted Sep 06, 2021 - 07:38 AEST
Update
Installation of Microsoft Software updates for the exchange server EXCH690 are still in process.
Posted Sep 04, 2021 - 08:03 AEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 03, 2021 - 21:56 AEST
Investigating
Exchange services are intermittently disconnecting. We are investigating the issue.
Posted Sep 03, 2021 - 18:49 AEST
This incident affected: MPexchange.