MParchive - archiving emails notifications
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Feb 09, 2024 - 10:05 AEDT
Investigating
Some emails are not being accepted by the MParchive service, and are generating bounce messages. The engineering team are looking into the issue as a matter of urgency. Once the issue has been identified, we will provide an update.
Posted Feb 06, 2024 - 16:34 AEDT
This incident affected: MParchive.