"Deliver Emails" from MPmail Portal

Incident Report for Manage Protect Pty Ltd

Resolved

This incident has been resolved
Posted Oct 14, 2025 - 09:04 AEDT

Identified

We have identified an issue with the re-delivery of emails from the MPmail admin portal that have been quarantined already.
Users selecting to "Deliver Email", after it has been quarantined are noticing emails are not being re-delivered.
We are currently working on a fix with the MPmail engineers.
Posted Oct 13, 2025 - 16:08 AEDT
This incident affected: MPmail.