Issue with Invoicing

Incident Report for Manage Protect Pty Ltd

Resolved

We have now reissued the April invoices
Posted Apr 08, 2026 - 17:43 AEST

Identified

We have identified an issue with the recent invoices issued. The information may not be 100% accurate and some subscriptions missing from the invoice. Our Account's team is aware of the issue and working on a resolution
Posted Apr 08, 2026 - 11:28 AEST