Converge outage

Incident Report for Manage Protect Pty Ltd

Resolved

The Converge portal is back online now. Please contact support on 1300 657 500 or via support@manageprotect.com if you are still unable to access Converge.
Posted Jun 23, 2025 - 12:48 AEST

Investigating

We are investigating an issue with our Converge portal that is resulting in it being inaccessible. We'll provide an update as soon as possible.
Posted Jun 23, 2025 - 12:28 AEST
This incident affected: Converge.