MPexchange Updates
Incident Report for Manage Protect Pty Ltd
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 11:54 AEST
Identified
There is a scheduled maintenance for the Partner Portal and Control Panel for MPexchange over the weekend and access to the Partner Portal or Control Panel will be temporarily restricted.
Please be assured, this event will not impact email processing, and users will still have access to all their applications.
Posted Apr 19, 2024 - 16:59 AEST
This incident affected: MPexchange.