MPmail control panel not working
Incident Report for Manage Protect Pty Ltd
Resolved
Control Panel is now operational.
Posted Jul 17, 2019 - 09:10 AEST
Monitoring
The MPmail control panel at https://control.manageprotect.com is currently not loading. This doesn't affect mail flow but it prevents releasing of emails or addition of services temporarily. You will be updated when control panel returns to operation.
Posted Jul 17, 2019 - 08:47 AEST
This incident affected: MPmail.